Jump to content

Не работают кнопки для добавления и удаления изображений в админке


Recommended Posts

При попытке вставить новое изображение или заменить его появляется блок с кнопками, которых нету. Такая ситуация со всеми изображениями во всей админке. Пробовал три раза переустановить, не помогло. Версия 3.0.3.8-ce.1.3. По логам все чисто.

В чистом opencart и ocstore такой проблемы не наблюдал, использовались конфиги сервера везде одинаковые.

Opera Снимок_2024-02-13_203429_tecmebel.ru.png

Edited by honoren
Link to comment
Share on other sites

В 13.02.2024 в 16:46, honoren сказал:

При попытке вставить новое изображение или заменить его появляется блок с кнопками, которых нету. Такая ситуация со всеми изображениями во всей админке. Пробовал три раза переустановить, не помогло. Версия 3.0.3.8-ce.1.3 В чистом opencart и ocstore такой проблемы не наблюдал, использовались конфиги сервера везде одинаковые.

Это может быть вызвано несколькими возможными причинами. Вот некоторые из них, которые стоит проверить:

1. Убедитесь, что у вас достаточно прав доступа к папкам и файлам OpenCart. Отсутствие прав на запись может привести к проблемам с загрузкой изображений. Установите права на запись (chmod) для папок `image`, `cache` и `admin` на сервере.

2. Проверьте правильность указания пути к изображениям в файле `config.php` и `admin/config.php`. Убедитесь, что путь указан правильно и ведет к папке `image` вашего сайта.

3. Проверьте, есть ли какие-либо ошибки PHP в журналах ошибок сервера. Если возникают ошибки, они могут помочь в определении причины проблемы.

4. Проверьте, чтобы в админке OpenCart не были включены какие-либо расширения или модификации, которые могут вызывать конфликты с загрузкой изображений. Если вы используете какие-либо расширения, попробуйте временно отключить их и проверить поведение загрузки изображений.

Если ни один из этих советов не помогает, возможно, вам потребуется обратиться к специалисту в области OpenCart для дополнительного анализа проблемы.

Link to comment
Share on other sites

На следующий день само починилось. Скорее всего кэш браузера и был. Но все равно не понятно, почему изначально он кнопки не захватил.
Спасибо за совет.

В 13.02.2024 в 22:11, mpn2005 сказал:

Смотрите в сторону кэша браузера.

Посмотрите ещё в консоль брузера, есть ли там ошибки загрузки.

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...